Bug report #12403

Labels get cut off from map canvas for some rotation / aspect ratio combinations

Added by Mike Taves over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Labelling
Affected QGIS version:2.8.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:20577

Description

Since QGIS 2.8, labels are removed from the canvas that would normally showed in QGIS 2.6. Consider some gridded point data, provided from PostGIS:

DROP TABLE IF EXISTS qgistest;
CREATE TABLE qgistest(
  gid serial PRIMARY KEY,
  name character(7)
);
SELECT AddGeometryColumn('qgistest', 'geom', 2193, 'POINT', 2);
INSERT INTO qgistest(geom)
SELECT ST_SetSRID(ST_MakePoint(i * 1000 + 1200000, j * 1000 + 5000000), 2193)
FROM generate_series(0, 20) AS i, generate_series(0, 15) AS j;
UPDATE qgistest SET name = substring(md5(geom::text) for 7);

Create a default sized map composer (e.g. A4) with a map placed in the center with a scale of about 50000. I've also added a North arrow. The points should have a label.

With most map rotations, such as 0° or 180°, everything looks normal:

With a rotation of 90°, labels are clipped off the left and right sides:

And similar at 270° too. From the last image, it appears that the labels that were clipped off have the same width as the height of the map.

Using a different aspect ratio shows a similar phenomena, but now clipped on the top and bottom sides:

Also note that the phenomena happens near 90°/270°, for example here is 75°:

But you wouldn't suspect at problem at 60°

History

#1 Updated by Mike Taves over 5 years ago

  • Tag set to rotation
  • Category set to Labelling

#2 Updated by Nyall Dawson over 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #12388

Also available in: Atom PDF