Bug report #12373

exporting 3D Postgis layer to shapefile loses the Z value

Added by Antonio Valanzano almost 5 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:2.8.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20547

Description

I have noticed that when exporting from a DB layer (PostGIS and SpatiaLite) with 3D features (i.e. PolygonZ, LinestringZ)
to a shapefile it has only x,y coordinates and not Z.
This doesn't happen with loaded 3D shapefiles which are correctly exported as 3D shapefiles.

Associated revisions

Revision 4e4743a2
Added by Nyall Dawson almost 4 years ago

Fix saving vector layers with z dimension (fix #14006, #12373)

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Category set to Vectors
  • Status changed from Open to Feedback

Hi,

do you get any error message? How do you export? save as...? DB Manager?

#2 Updated by Antonio Valanzano almost 5 years ago

Giovanni Manghi wrote:

Hi,

do you get any error message? How do you export? save as...? DB Manager?

I didn't receive any error message.
I did the export using "save as" and DB Manager and the result was always the same (Z coordinate is missing)

#3 Updated by Giovanni Manghi almost 5 years ago

what about the (ogr) convert format tool in the Processing toolbox?

#4 Updated by Giovanni Manghi about 4 years ago

  • Subject changed from error in exporting 3D shapefile from DB layer to exporting 3D Postgis layer to shapefile loses the Z value
  • Status changed from Feedback to Open

see also #14006

#5 Updated by Nyall Dawson almost 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF