Bug report #12369

Multiple rasters opening one on top of another

Added by Nick Nourse over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Rasters
Affected QGIS version:2.8.1 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:20544

Description

Georeferenced raster data downloaded from Digimap that has previously opened (v.2.2) in its correct geographic location, in v2.8 multiple tiles open in the same location, one on top of the other. Rendering is also very slow.
Manually changing the CRS of raster files has no effect: the tiles remain on top of each other. Continued changing of CRS in tiles -- usually on 5th tile -- QGIS crashes. DMP files are 17Mb.
Employing Raster/Miscellaneous/Merge mosaics the tiles together correctly. Also loading an old VRT file calling the same raster tiles loads correctly.
The issue is present when opening and old (v.2.2) QGS file, and when the raster files are opened in a new project.
This may be a fault in the raster file, but the issue was not apparent in v2.2.
Other files sourced from Digimap open correctly.

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Crashes QGIS or corrupts data changed from Yes to No
  • Status changed from Open to Feedback

Please attach sample data.

#2 Updated by Nyall Dawson over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Already fixed in master and will be resolved in 2.8.2

Also available in: Atom PDF