Bug report #12363

crash in QgsPalettedRasterRenderer when saving pixmap layer

Added by Henrik Hartz about 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Rasters
Affected QGIS version:2.8.1 Regression?:No
Operating System:Mac OS X Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:Yes Copied to github as #:20538

Description

latest dev branch will crash when attempting to save certain pixmap layers as .vrt, with the final method in the stacktrace on QgsPalettedRasterRenderer

see attached file for full stack trace

qgis-crash.log Magnifier (92.5 KB) Henrik Hartz, 2015-03-12 02:09 AM

History

#1 Updated by Martin Dobias almost 5 years ago

  • Status changed from Open to Feedback

Please attach source layer and parameters used when doing save raster operation

#2 Updated by Jürgen Fischer over 4 years ago

  • Category set to Rasters

#3 Updated by Nyall Dawson over 4 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Closed due to lack of feedback

Also available in: Atom PDF