Bug report #12338

Field Calculator on PostGIS layer corrupt project file

Added by Remi Cura over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Field calculator
Affected QGIS version:2.6.1 Regression?:No
Operating System:Win XP Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:20514

Description

Only on 2.6, works on 2.8

Using a POstGIS layer, using the Field Calculator to update a selection of geometry.
This does nothing, and corrupt the layer so that even closing/reloading the project the layer is still corrupted.
One has to manually delete and reimport the layer to work with it again.

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Open to Feedback

I don't think there will be backports for 2.6, so if it works in 2.8 this should be closed, agree?

#2 Updated by Nyall Dawson over 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

If it's fixed in 2.8, this can be closed

Also available in: Atom PDF