Bug report #12335

Processing can't find SAGA in Debian [regression]

Added by Borys Jurgiel almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Victor Olaya
Category:Processing/SAGA
Affected QGIS version:master Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:20511

Description

When starting Processing, it looks for SAGA by running subprocess.Popen(['saga_cmd', '-v'], shell=True) in SagaUtils.getSagaInstalledVersion
However, at least in Debian, passing arguments as a list seems to not work in the shell mode, so it should be either simple 'saga_cmd -v', or the shell mode should be False.

Associated revisions

Revision eaf17e56
Added by Martin Dobias over 4 years ago

Fix SAGA detection on some Debian/Ubuntu systems (fixes #12335)

Revision 230ff6f8
Added by Martin Dobias over 4 years ago

Fix SAGA detection on some Debian/Ubuntu systems (fixes #12335)

(cherry picked from commit eaf17e56c2ff6c74eb43319096a177fc301d5a39)

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Open to Feedback

is this still true?

#2 Updated by Paolo Cavallini over 4 years ago

Not confirmed here, on Sid.

#3 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

closing for lack of feedback.

#4 Updated by Borys Jurgiel over 4 years ago

Sorry, it's a pitty the hub doesn't send any email notification when the status is changed to feedback.

Now in master it's even worse - Saga is completely gone from the algorithm tree.

#5 Updated by Jürgen Fischer over 4 years ago

  • Status changed from Closed to Feedback

#6 Updated by Giovanni Manghi over 4 years ago

Borys Jurgiel wrote:

Sorry, it's a pitty the hub doesn't send any email notification when the status is changed to feedback.

Now in master it's even worse - Saga is completely gone from the algorithm tree.

do you have at least saga 2.1.2 installed? Processing do not support anymore any saga version lower than 2.1.2

#7 Updated by Borys Jurgiel over 4 years ago

Yes, 2.1.2. I'll investigate it later this week.

#8 Updated by Martin Dobias over 4 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF