Bug report #12327

Metasearch overwriting connections

Added by Paolo Cavallini over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:Tom Kralidis
Category:MetaSearch Catalogue Client
Affected QGIS version:2.8.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:20505

Description

When adding a WMS or WFS connection from Metasearch results lists, always the same name is used, so the connection is overwritten (with a warning). Better add is as a default always with a different name (e.g. with a serial)

History

#1 Updated by Tom Kralidis over 4 years ago

  • Assignee changed from Tom Kralidis to Richard Duivenvoorde

iirc, we have such an option in settings (overwrite, save to a static title, use title from Capabilities XML, etc.)

cc'ing Richard here as I don't recall why we removed it.

#2 Updated by Tom Kralidis over 4 years ago

We had this implemented, but took it out:

discussion: http://lists.osgeo.org/pipermail/qgis-developer/2014-August/034415.html

commit: https://github.com/geopython/MetaSearch/commit/7ad8f0fbe69e3fdb7964b2098a8d7ed15cd8aef2

irc convo with duiv:

] duiv for what I now, we made an option for that
[07:25] duiv lemme look
[07:25] tomkralidis yeah it's not there anymore.
[07:25] tomkralidis I remember we took it out, there was discussion around it I think
[07:26] duiv not with me I think
[07:26] duiv I would not have removed it
[07:26] duiv because sometime you want to overwrite
[07:27] duiv but I can also think of usecases where you want every ows server to 'transfer' from the metadata to qgis with its own connection name...
[07:29] tomkralidis ah, ok: https://github.com/geopython/MetaSearch/commit/7ad8f0fbe69e3fdb7964b2098a8d7ed15cd8aef2
[07:29] tomkralidis http://lists.osgeo.org/pipermail/qgis-developer/2014-August/034415.html
[07:31] duiv ^^^ is that related to the removal of the checkbox?
[07:31] tomkralidis I think the fact that we were having so many issues around connection naming we went with a default naming
[07:32] duiv mmm, I do not recall that the original idea gave issues.
[07:32] duiv 'in the beginning'
[07:32] duiv we used the 'service-url' as key/name for the connection
[07:33] duiv because I tested so much services, I ended up with 20 connections that I had to throw away later
[07:33] tomkralidis we can bring it back, no problem, I'm just trying to recall the history
[07:33] duiv so I proposed to use a fixed name for that connection and made that optional
[07:34] duiv I think later it has become more complex, because instead of the service-url we apparently tried to find out the service name etc
[07:34] duiv for which we needed the capabilities etc etc
[07:35] duiv so my stand: bring the original back: either the service-url as key, or a fixed name, and a simple checkbox option to choose from

#3 Updated by Paolo Cavallini over 4 years ago

  • Assignee changed from Richard Duivenvoorde to Tom Kralidis

So, what are the plans?
Thanks.

#4 Updated by Tom Kralidis over 4 years ago

I will add this back in.

#5 Updated by Tom Kralidis over 4 years ago

After further discussion with Richard, the proposal is to either overwrite the connection or to rewrite it with a serial suffix, i.e.:

  • wfs from MetaSearch 1
  • wfs from MetaSearch 2

Having said this, I see 2 workflow options to enable this:

1./ enable as a MetaSearch setting, adding a connection will take into account the setting without prompting the user
2./ always prompt the user to overwrite, if yes, then overwrite, if no, then rewrite with serial

Thoughts? Other workflow options?

#6 Updated by Paolo Cavallini over 4 years ago

IMHO overwriting should not occur. adding a serial seems fine to me. If you think it is important to give the option to overwrite, better ask at every Save.

#7 Updated by Tom Kralidis over 4 years ago

fixed in ff52a05 with option 2

#8 Updated by Richard Duivenvoorde over 4 years ago

@paolo I really do not like option 2

For me I use the metadata tool to 'try out' or 'search' for services, eg means trying a lot of different services from our national metadata services. Meaning I have >20 wms connections in QGIS which I actually do not want.
I can overwrite now, but will always have a prompt, which I consider a bad solution.

I always(!) want to overwrite the connection from the MetaSearch tool, as the purpose is not really loading a wms, the purpose is to quickly test/look at a service.

#9 Updated by Tom Kralidis over 4 years ago

I have added the settings option back in in master (519830e) and updated the user manual/docs to reflect (see PR at https://github.com/qgis/QGIS-Documentation/pull/496). Please reopen the ticket if there are outstanding issues.

#10 Updated by Tom Kralidis over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Also available in: Atom PDF