Bug report #12322

load tif/tfw layer with rotation terms

Added by Otto Dassau about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Rasters
Affected QGIS version:2.8.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:20500

Description

Hi,

when I load a tif with worldfile and the 2nd and 3rd row (rotation terms) is not 0, QGIS is not able to put the layer to the right position. I also tested with QGIS Version 2.6.1 and there it works.

With this tfw file the layer is not shown at the correct position:

0.317133539233554
-0.012952088380440
-0.012952088380440
-0.317133539233554
386370.45256274
5674529.73223443

With this tfw file the layer is shown at the correct position but the
rotation is missing.

0.317136839634324
0.000000000000000
0.000000000000000
-0.317136839634324
384372.80934352
5674611.33286690

Thanks a lot
Otto

History

#1 Updated by Giovanni Manghi about 5 years ago

  • Priority changed from Normal to Severe/Regression
  • Category set to Rasters

I assume then that is a regression.

#2 Updated by Nyall Dawson about 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #12308

Also available in: Atom PDF