Bug report #12314

QGIS crashes when creating a raster layer histogramm

Added by Patrick Patrick over 4 years ago. Updated over 4 years ago.

Status:Rejected
Priority:Normal
Assignee:-
Category:Processing/QGIS
Affected QGIS version:2.8.1 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:20492

Description

Hello,

I used the 'raster layer histogram' for the first time on a elevation raster (DEM / file: TIFF).

I get an error which seems to appear at the end of the process.

Screenshot attached.

2015-03-04_17h39_24.png (141 KB) Patrick Patrick, 2015-03-04 08:47 AM

History

#1 Updated by Patrick Patrick over 4 years ago

  • Assignee deleted (Victor Olaya)

#2 Updated by Giovanni Manghi over 4 years ago

cannot confirm here on both Linux and Windows. Please attach sample data.

#3 Updated by Radoslaw Guzinski over 4 years ago

I can confirm it on my computer (QGIS 2.8.1 from OSGeo4W, Windows 7, 64 bit). The crash seems to be caused by this issue: http://trac.osgeo.org/osgeo4w/ticket/451

A temporary fix is to replace matplotlib 1.3.1 with matplotlib 1.3.0 using the OSGeo4W installer.

#4 Updated by Alexander Bruy over 4 years ago

  • Resolution set to worksforme
  • Status changed from Open to Rejected

Works fine in master and 2.8.1, Seems this is not Processing nor QGIS issue but bug in the specific matplotlib version/build.

Also available in: Atom PDF