Bug report #12299

Connection error when using German umlaut in search string

Added by Tobias Preuss about 5 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:MetaSearch Catalogue Client
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:20477

Description

I am trying to search within this catalog.
When I include German umlaut such as ä or ü in the search string the following error message pops up:

Connection error: 'ascii' codec can't encode character u'\\xe4 in position 723: ordinal not in range(128)

I use QGIS 2.8.1. with MetaSearch 0.3.3.

metasearch-connection-error-umlaut.png - Screenshot of the connection error (70.2 KB) Tobias Preuss, 2015-03-02 12:06 PM

History

#1 Updated by Tom Kralidis about 5 years ago

I can't reproduce this at all with the same QGIS and MetaSearch versions (on Windows). I'll keep testing, perhaps if others can try on other OSs?

#2 Updated by Tobias Preuss about 5 years ago

I use Ubuntu 14.04.

#3 Updated by Tom Kralidis over 4 years ago

  • Crashes QGIS or corrupts data set to No
  • Project changed from 218 to QGIS Application

#4 Updated by Tom Kralidis over 4 years ago

  • Affected QGIS version set to master
  • Category set to MetaSearch Catalogue Client

#5 Updated by Tom Kralidis about 4 years ago

  • Status changed from Open to Closed
  • Resolution set to not reproducable

#6 Updated by Tobias Preuss about 4 years ago

  • Status changed from Closed to Reopened

I just tested with MetaSearch 0.3.4 and QGIS 2.14.1 on 15.10. The error remains.
Here is the GetCapabilities for the CSW I use:

http://fbinter.stadt-berlin.de/fb/csw/?REQUEST=GetCapabilities&SERVICE=CSW&VERSION=2.0.2

#7 Updated by Tom Kralidis over 3 years ago

Hi Tobias: I still cannot reproduce. Can you provide some test keywords you are using?

#8 Updated by Tom Kralidis about 3 years ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF