Bug report #12275

Diagrams shown only for one layer, forever

Added by Kevin Darras about 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Diagrams
Affected QGIS version:2.8.0 Regression?:No
Operating System:Windows Seven Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20458

Description

I am not sure whether everyone has the same problem, but here it is:

I have a nice project file in Qgis 2.6.1 with lots of layers. Sometimes I need to show diagrams from either one layer or the other.

However it seems that the layer for which I generated diagrams first prevents the diagram generation for other layers, even after unchecking/hiding them. The only solution is to to a new project file and re-import the layers.

You can try that with the two test files I attached here.

test_files.zip (51.5 KB) Kevin Darras, 2015-02-26 03:51 AM

diagrams_not_showing_for_all_layers.qgs (40.4 KB) Kevin Darras, 2015-03-03 07:03 AM

diagrams.png (200 KB) Giovanni Manghi, 2015-03-04 04:56 AM

diagrams_not_showing_for_point_layer.png (644 KB) Kevin Darras, 2015-03-05 11:00 PM

all_diagrams_displayed.PNG (35.2 KB) Kevin Darras, 2015-04-13 05:53 PM

History

#1 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Open to Feedback

Hi,

I cannot see this issue, or maybe I haven't understand it.

It would be better to attach a sample project, were you have configured the diagram options that in your case are causing the described issue.

#2 Updated by Kevin Darras about 5 years ago

Thanks for your answer.

Here is the project file that you can use along with the layer files I sent.

Actually it does not seem to depend on which layer you enable diagrams for. I tried to repeat it here but this time the diagrams just don't show for the points layer, although they do for the polygon layer (and they did some other time I tried).

#3 Updated by Giovanni Manghi about 5 years ago

I can see diagrams from both layers, see attached image. Isn't this what you are getting?

#4 Updated by Kevin Darras about 5 years ago

No, I don't see the smaller pie charts at all. I disabled all plugins that I installed additionally to the default ones and I still have the same problem.

#5 Updated by Giovanni Manghi about 5 years ago

Kevin Darras wrote:

No, I don't see the smaller pie charts at all. I disabled all plugins that I installed additionally to the default ones and I still have the same problem.

I'm lost, I cannot uderstand what diagrams do not show, can you post a screenshot describing the issue? thanks.

#6 Updated by Kevin Darras about 5 years ago

As I said, I don't see the smaller pie charts of the point layer (screenshot attached). Even when I check the box to show all diagrams including colliding ones.

#7 Updated by Giovanni Manghi about 5 years ago

Kevin Darras wrote:

As I said, I don't see the smaller pie charts of the point layer (screenshot attached). Even when I check the box to show all diagrams including colliding ones.

do you acknowledge that i the image I attached here the diagrams are visible? try exclude factors like 3rd party plugins.

#8 Updated by Nyall Dawson almost 5 years ago

Can you test again with current master version? A lot of diagram related fixes have landed which may have solved this.

#9 Updated by Kevin Darras almost 5 years ago

Problem solved, thank you very much.

Also available in: Atom PDF