Bug report #12274

QGIS Python plugin upload not working

Added by Dennis Ligtenberg almost 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Normal
Assignee:Alessandro Pasotti
Category:-
Pull Request or Patch supplied:No

Description

The upload of a QGIS Python plugin (via website http://plugins.qgis.org/plugins/add/) does not seem to work.
Trying to upload the plugin redirects me to an Error 500 page.
I was able to upload another plugin (experimental though) in the same session without an error.

Here a link to the plugin repository:
https://github.com/geometalab/Quiz-QGIS-Plugin

History

#1 Updated by Giovanni Manghi almost 7 years ago

  • Project changed from QGIS Application to QGIS Plugin Site
  • Category deleted (Python plugins)

#2 Updated by Alessandro Pasotti almost 7 years ago

Can you reproduce the error?

Is sounds like a temporary server issue, we have had a few lately.

#3 Updated by Dennis Ligtenberg almost 7 years ago

Alessandro Pasotti wrote:

Can you reproduce the error?

Is sounds like a temporary server issue, we have had a few lately.

I just tried again and it still seems not to work.

#4 Updated by Alessandro Pasotti almost 7 years ago

Ok, so please:

1. attach the plugin
2. describe step by step how you upload the plugin (there are 3 different ways to do it)

#5 Updated by Alessandro Pasotti almost 7 years ago

  • Status changed from Open to In Progress

Forget about it: found the issue.

Your zip file is probably corrupted and does not pass zipfile internal test made by the library. The error wasn't catched correctly, I'm going to upload a fix.

#6 Updated by Alessandro Pasotti almost 7 years ago

  • Status changed from In Progress to Closed
  • Assignee set to Alessandro Pasotti

Fix deployed.

#7 Updated by Dennis Ligtenberg almost 7 years ago

  • Status changed from Closed to Reopened

It still does not work... Same error.
I'm trying to upload here: https://plugins.qgis.org/plugins/add/

The file is larger than the max 5MB you can upload here, but it's basically the ziped version of the repository minus all the git files.
https://github.com/geometalab/Quiz-QGIS-Plugin

Edit: Uploaded the zip to Dropbox: https://www.dropbox.com/s/lse8g3eprwk7n07/QuizQGISPlugin.zip?dl=0

#8 Updated by Alessandro Pasotti almost 7 years ago

Now it's a different error.

Can you please attach the zip file you are trying to upload?

Without that I won't be able to track the issue.

#9 Updated by Dennis Ligtenberg almost 7 years ago

Alessandro Pasotti wrote:

Now it's a different error.

Can you please attach the zip file you are trying to upload?

Without that I won't be able to track the issue.

You can find it here:
https://www.dropbox.com/s/lse8g3eprwk7n07/QuizQGISPlugin.zip?dl=0

#10 Updated by Alessandro Pasotti almost 7 years ago

I'm not able to download from dropbox (I have no account).

There is a nice feature that allows to upload an attachment here, please use it now.

#11 Updated by Dennis Ligtenberg almost 7 years ago

Alessandro Pasotti wrote:

I'm not able to download from dropbox (I have no account).

There is a nice feature that allows to upload an attachment here, please use it now.

I can't, since the upload limit is 5MB.
Can you download it from here: https://owncloud.hsr.ch/public.php?service=files&t=848272a9de9f37c13bb23c406c77ab27

#12 Updated by Alessandro Pasotti almost 7 years ago

The problem is with Belizè.png , zip function doesn't like unicode in file names.

I'm working on a fix, but in the meantime you can just rename that file and possibily other file names to ASCII.

#13 Updated by Nathan Woodrow almost 7 years ago

Alessandro Pasotti wrote:

I'm not able to download from dropbox (I have no account).

There is a nice feature that allows to upload an attachment here, please use it now.

You don't need an account to download. Just follow the link and press download.

#14 Updated by Alessandro Pasotti almost 7 years ago

Thanks Nathan, that's exactly what I did, but I was prompted for a login or create a new account.

#15 Updated by Alessandro Pasotti almost 7 years ago

  • Status changed from Reopened to Closed

It sounds like there is not an easy fix for this problem, python zip library support for unicode filenames is not complete because there is not a defined way to treat unicode file names in the zip format itself.

So, for now we don't accept unicode filenames in plugins and I've added a try/except block to catch the UnicodeDecodeError and now it should print a proper error message with the bad file name.

Also available in: Atom PDF