Bug report #12241

WMTS and 2.8

Added by Randal Hale over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:2.8.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No

Description

In 2.6 and 2.7 (master) I could add this tile service using the WMS/WMTS icon: http://services.arcgisonline.com/arcgis/rest/services/World_Imagery/MapServer/WMTS/1.0.0/WMTSCapabilities.xml

With 2.8 it appears to not being working. This works though: qgis.utils.iface.addRasterLayer("http://services.arcgisonline.com/ArcGIS/rest/services/World_Imagery/MapServer?f=json&pretty=true","raster")

I'm not noticing anything getting announced in the logs. So I'm no help there.


Related issues

Duplicated by QGIS Application - Bug report #12244: WMTS does not load Tiles/Map (QGIS 2.8 Ubuntu) Closed 02/24/2015

Associated revisions

Revision 6de2828d
Added by Jürgen Fischer over 2 years ago

fix wmts (fixes #12241; followup 1e97b62c)

Revision 251aca6d
Added by Jürgen Fischer over 2 years ago

fix wmts (fixes #12241; followup 1e97b62c)

History

#1 Updated by Giovanni Manghi over 2 years ago

  • OS version deleted (7)
  • Operating System deleted (Windows )
  • Target version changed from Version 2.8 to Version 2.8.1
  • Priority changed from Normal to Severe/Regression
  • Category set to Web Services clients/WMS

Confirmed, works ok on 2.6.1, does not on 2.8 and master.

#2 Updated by Jürgen Fischer over 2 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF