Bug report #12181

Attributes table: can't unselect lines by dragging the cursor up

Added by Filipe Dias over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Attribute table
Affected QGIS version:2.6.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:20371

Description

Steps to reproduce:

- Select one line of the attributes table

- Drag the selection a few lines down

- Try dragging the selection up to unselect the last three lines

- it doesn't work

I remember this worked a few versions ago but I'm not sure.

History

#1 Updated by Nathan Woodrow over 5 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

I don't think it ever worked like that. If you hold Ctrl when dragging over cells it will unselect.

#2 Updated by Filipe Dias over 5 years ago

Thanks, using Ctrl + drag up I can unselect lines. I was relatively sure it used to work like this, but I may be thinking of ArcGIS or SAGA.

Is there a reason (technical or otherwise) for this behaviour? It's the behaviour one would intuitively expect since it's how Calc/Excel and also SAGA GIS work.

Also available in: Atom PDF