Bug report #12120

QGis Server: WMS - rules?

Added by Jeffrey Bostoen about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:2.6.0 Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:20314

Description

For some reason - maybe it is by design? - the WMS seems to ignore the rules I've set for a particular shapefile ("lyr_mob_strooiplan"). When setting up the service in QGis Desktop, it renders perfectly. But the legend (PNG) only shows the 2 categories but in black?

Maybe I'm missing something?
.QGS-file attached.

strooiplan.qgs (65.2 KB) Jeffrey Bostoen, 2015-02-03 08:31 AM

Sneeuw.zip (28 KB) Jeffrey Bostoen, 2015-02-03 11:53 PM

wms.png (286 KB) Giovanni Manghi, 2015-02-04 01:42 AM

History

#1 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Open to Feedback

the project file without the data does not help.

#2 Updated by Jeffrey Bostoen about 5 years ago

Here's the shapefile. ( lyr_mob_strooiplan ).
When viewing the WMS, I only see darker polylines, without colors. Same thing if I alter it to a single symbol.

I might be overlooking something, perhaps I need to define the style in a different way?

I've also been googling on some proper documentation about how the STYLE parameter works for the MapServer's WMS, but haven't found anything useful yet?

#3 Updated by Giovanni Manghi about 5 years ago

Jeffrey Bostoen wrote:

Here's the shapefile. ( lyr_mob_strooiplan ).
When viewing the WMS, I only see darker polylines, without colors. Same thing if I alter it to a single symbol.

I might be overlooking something, perhaps I need to define the style in a different way?

I've also been googling on some proper documentation about how the STYLE parameter works for the MapServer's WMS, but haven't found anything useful yet?

attached an image as your layer/project looks like when loaded as WMS layer using QGIS server. Seems ok to me.

#4 Updated by Jeffrey Bostoen about 5 years ago

  • Status changed from Feedback to Closed

My bad. I just did a clean re-install of the QGis-server package and it works perfectly.

#5 Updated by Giovanni Manghi about 5 years ago

  • Resolution set to invalid

Also available in: Atom PDF