Bug report #11991

Grid annotation distance to map frame not initialized correctly

Added by Sandro Santilli about 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Decorations
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20197

Description

It looks like the "distance to map frame" parameter of grid decoration annotations is not retained.
To test:

- Enable grid, set show annotations and "distance to map frame" = 16
- Click on Apply, see grid annotation offsetted from frame
- Close dialog (OK)
- Re-open GRID dialog, the distance to map frame is now 0

NOTE: the value is correctly saved to project file and used from there, but it is not shown correctly in the dialog.

Associated revisions

Revision d45eea1e
Added by Nyall Dawson almost 5 years ago

Fix grid annotation distance not restored in dialog (fix #11991)

Revision 88b14c0c
Added by Nyall Dawson almost 5 years ago

Fix grid annotation distance not restored in dialog (fix #11991)

History

#1 Updated by Nyall Dawson almost 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF