Bug report #11969

WFS-GetFeature broken (with "caching" unchecked)

Added by Benjamin Schepers over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:-
Affected QGIS version:2.6.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:20176

Description

I'm using the latest QGIS 2.6.1 and don't get get the features from a WFS, when caching is unchecked in the wfs loader.
If caching was checked everything seems to work well.

Analyzing the sever-site requests gave the following results from the logs:

WITH Cache-Features checked:
blabla/bla?SERVICE=WFS&REQUEST=GetCapabilities&VERSION=1.0.0
blabla/bla?SERVICE=WFS&VERSION=1.0.0&TYPENAME=test&&REQUEST=DescribeFeatureType
blabla/bla?SERVICE=WFS&VERSION=1.0.0&REQUEST=GetFeature&TYPENAME=test&SRSNAME=EPSG:25832

WITHOUT Cache-Features:
blabla/bla?SERVICE=WFS&REQUEST=GetCapabilities&VERSION=1.0.0
blabla/bla?SERVICE=WFS&VERSION=1.0.0&TYPENAME=test&BBOX=342300.2220367033733055,5702838.80950548313558102,342795.02078515768516809,5703155.46760591678321362&REQUEST=DescribeFeatureType
blabla/bla?SERVICE=WFS&VERSION=1.0.0&REQUEST=GetCapabilities&TYPENAME=test&SRSNAME=EPSG:25832&BBOX=342300.2220367033733055,5702838.80950548313558102,342795.02078515768516809,5703155.46760591678321362

GetCapabilities worked well in both scenarios; with Caching unchecked, the BBOX-Parameter appears (seems alright), but the REQUEST-Parameter is wrong (GetCapabilities instead of GetFeature!)
=> the QUERY-String on the clientside is composed in a wrong way, with Parameter "caching" unchecked!

Please have a look at this

Thx

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #11968

Also available in: Atom PDF