Bug report #11950

exporting Atlas features with Output to multiple files creates and overwrites single file with Selected Folder name

Added by Daniel Ruddell almost 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.6.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20158

Description

When exporting Atlas features with Output to multiple files (i.e., 'Single file export when possible' checked OFF) and using either the Atlas export menu or the Atlas Preview menu, Select Folder, the export then creates a single page file of the current atlas feature with the name of the Selected Folder (in directory one folder up from Selected Folder)and repeatedly overwrites this file as each atlas feature is exported. When export is complete only the last feature remains; Abort leaves the pdf with the last feature exported.
Issue was reproduced with exports to Image as well (jpg and png were tried).

Steps to reproduce:
1 - Create a set of features for Atlas generation
2 - Export file name set to be based on one of the attribute fields (attempted with both $atlasfeature and $currentfeature)
3 - Select Folder
4 - Export

Expected behavior:
Folder with multiple output files for all Atlas features. This feature worked fine for me in mid-November 2014, creating a folder of multiple output files of one page for each feature.

History

#1 Updated by Nyall Dawson almost 7 years ago

  • Status changed from Open to Feedback

Works fine here - and nothing relevant has changed in the composer/atlas code since 2.6. Can you please post the expression you're using for the output filename?

#2 Updated by Daniel Ruddell almost 7 years ago

  • Status changed from Feedback to Closed

Resolved, not a bug. Problem was trying to use 'attribute' for output file name; simply entering the field names generates the desired result.
Humble apologies.

Also available in: Atom PDF