Bug report #11845

QGIS startup is slow on windows with --configpath option

Added by Regis Haubourg over 5 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:2.6.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20061

Description

Hi all,
we experience very slow startup (from 1 to 5 minutes) on windows with QGIS 2.x (last test with 2.6.1) when using remote profiles with --configpath option.
Whole topic and process monitor logs are available here.
This is related to QGIS trying to create files in C:\\Windows\\CSC\\v2.0.6\\, a system folder dedicated to store offline data, and that has special permissions..

Second startup is sometimes fast, sometimes slow.

repetitive_ini_reading_pattern.jpg (314 KB) Regis Haubourg, 2014-12-15 05:19 AM

History

#1 Updated by Martin Dobias over 5 years ago

  • Status changed from Open to Feedback

Not sure if this is really QGIS problem. If you use --configpath to an ordinary path on your local disk, would it be still slow?

My impression is that the system/network configuration for your shared folder might be the reason for slowness.

#2 Updated by Regis Haubourg over 5 years ago

I am confuzed, I run the same tests as yesterday, and I have no more that file creation error.
Everything goes well wherever I move qgis profile. Nasty problem.
I will try to reproduce it again..

#3 Updated by Regis Haubourg over 5 years ago

New tests today, problem is back..
I found several things:
- Microsoft CSC cache is due to offline sync of some files. No part of qgis was involved in sync but I disabled sync, and now the error pointing to C:\\Windows\\CSC\\v2.0.6\\ disappeared.
It is now replaced by several errors locating ressources that do not exists.

Among them, I found a repetitive pattern occuring all process life time, and related to QGIS.ini file.
First reading to actual remote_path\\.qgis2\\QGIS\\QGIS2.ini path is OK, but then QGIS tries to read old 1.x QGIS.ini or QGIS2.ini in other locations:
- remote_path\\.qgis2\\QGIS.ini
- C:\\ProgramData\\QGIS\\QGIS2.ini
- C:\\ProgramData\\QGIS2.ini

See attached picture repetitive_ini_reading_pattern.jpg

#4 Updated by Nathan Woodrow almost 5 years ago

hmm I'm seeing this now too and it only just started. Very strange. Seeing the same stuff in the logs.

#5 Updated by Jürgen Fischer over 4 years ago

  • Category set to Project Loading/Saving
  • Subject changed from QGIS startup is slow on windows with --confipath option to QGIS startup is slow on windows with --configpath option

#6 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Feedback to Open

#7 Updated by Giovanni Manghi about 3 years ago

  • Status changed from Open to Feedback
  • Priority changed from High to Normal

What it the status of this issue when tested against recent qgis releases?

#8 Updated by Regis Haubourg about 3 years ago

I think this a nasty issue, hard to reproduce. I would keep that open until that black magic est solved

#9 Updated by Giovanni Manghi about 3 years ago

  • Status changed from Feedback to Open

#10 Updated by Giovanni Manghi almost 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#11 Updated by Regis Haubourg over 1 year ago

  • Status changed from Open to Closed
  • Description updated (diff)

QGIS 3 is arriving as next LTR, and confipath option has changed. Please reopen if necessary

Also available in: Atom PDF