Bug report #11836

"Drag and drop designer" crashes QGIS when a text edit, multiline field is repeated more than once

Added by Giedrius Vaivilavičius almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Forms
Affected QGIS version:2.8.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:20054

Description

New description:

Add a layer

use D&D design to add into two different tabs the same text field with a multiline text edit widget

try add a feature > crash

not sure if it is a regression.

Old description:

Using "Drag and drop designer" has made a form with different types of grounds but they are duplicated fields. Then QGIS crashes when I put the point. The terminal writes "Segmentation fault". When I eliminate fields that are repeated, then no crashes. QGIS 2.6.1 Debian wheezy 64 bit.

widget_text.png (32.6 KB) Giedrius Vaivilavičius, 2014-12-10 11:55 PM

form_su_text.png (27.9 KB) Giedrius Vaivilavičius, 2014-12-10 11:55 PM

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Status changed from Open to Feedback
  • Priority changed from Normal to High

I just tested with data of my own (PostGIS), on Linux and Windows, and cannot replicate, even duplicating on purpose an attribute in the D&D designer.

Does it happens with any layer?

#2 Updated by Giedrius Vaivilavičius almost 5 years ago

The problem is in "edit widget" when selected "Multiline". No crashes when marking "Multiline" removed. I've tried to shap, SQLite and PostGIS layers.

#3 Updated by Giovanni Manghi almost 5 years ago

  • Operating System deleted (Debian Wheezy)
  • Subject changed from Using "Drag and drop designer" QGIS 2.6 crashes when I put the point to "Drag and drop designer" crashes QGIS when a text edit, multiline field is repeated more than once

#4 Updated by Jürgen Fischer almost 5 years ago

  • Status changed from Feedback to Open

#5 Updated by Giedrius Vaivilavičius over 4 years ago

  • Target version set to Future Release - High Priority

The problem persists on 2.8.0 version

#6 Updated by Giovanni Manghi over 4 years ago

  • Affected QGIS version changed from 2.6.1 to 2.8.0

#7 Updated by Matthias Kuhn over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Fixed in 2bd39e264e6

#8 Updated by Giedrius Vaivilavičius over 4 years ago

On 2.9 master it works. no crashes. Thank you for your work!

Also available in: Atom PDF