Bug report #11825

fill with centroid draws symbol outside the polygons

Added by matteo ghetta over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System:debian, windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20043

Description

In a certain scale range (1:250,000 - 1:5,000) the fill with centroid style behavior appears weird.
Centroids are drawn also outside the polygons in the upper left corner where no polygon exists.

Attach contains some images, a shapefile and a project file.

BTW: QGIS 2.6, 2.6.1 and 2.7 (master)

ticket.zip (1.42 MB) matteo ghetta, 2014-12-09 06:38 AM

Associated revisions

Revision b26556e5
Added by Martin Dobias over 5 years ago

Fix #11825 - handle centroid calculation also for invalid geometries

The on the fly simplification can corrupt geometries so let's try to deal
with it best we can

History

#1 Updated by Paolo Cavallini over 5 years ago

  • Priority changed from Normal to Severe/Regression

Apparently a regression

#2 Updated by Martin Dobias over 5 years ago

  • Status changed from Open to Feedback

I cannot reproduce. Does it happen just sometimes?

Will it happen if you disable simplification?

Will it happen if you force point on surface in centroid fill properties?

#3 Updated by Giovanni Manghi over 5 years ago

  • Affected QGIS version changed from 2.6.0 to master
  • Status changed from Feedback to Open

Martin Dobias wrote:

I cannot reproduce. Does it happen just sometimes?

Will it happen if you disable simplification?

Will it happen if you force point on surface in centroid fill properties?

steps to replicate:

  • open the attached project
  • zoom to full
  • add to project the attached shapefile "case6"
  • enter the newly added layer properties and change symbology to "centroid fill". A point symbol will show in the upper left corner of the canvas.

#4 Updated by Martin Dobias over 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF