Bug report #11807

Make "timestamp" datatype available for PostGIS vectors

Added by Giovanni Manghi almost 6 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:Jürgen Fischer
Category:Data Provider/PostGIS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:20031

Description

If you use the "date/time" edit widget to try save date and time in a "date" postgis column, then the time is discarded because the "date" datatype is only for dates.

http://www.postgresql.org/docs/9.3/static/datatype-datetime.html

if you want to save also the time the column must be of type "timestamp", but this type is not available in the "field" tab of the vector properties (nor is in the field calculator, but is available in DB Manager).

History

#1 Updated by Nyall Dawson almost 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Fixed in 0356752c641f4456b377f944c536274124cee23d

Also available in: Atom PDF