Bug report #11764

Primary digitizing tools do not work in QGIS 2.6 (create and divide polygons by hand)

Added by Lars Wikars about 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:2.6.0 Regression?:No
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:19996

Description

I try to use the digitising tools in QGIS 2.6 in the same way as I did in QGIS 2.2 (creating new polygons, dividing already existing polygons, shanging the shape of polygons). None of these actions work any more in QGIS 2.6. The whole process seems to freeze, while doing this. It also starts the digitizing process randoomly at the map, and not where I put down the cursor.

Atgard-uppdeladpolygon.dbf (393 KB) Lars Wikars, 2014-11-30 07:40 AM

Atgard-uppdeladpolygon.prj (379 Bytes) Lars Wikars, 2014-11-30 07:40 AM

Atgard-uppdeladpolygon.qpj (570 Bytes) Lars Wikars, 2014-11-30 07:40 AM

Atgard-uppdeladpolygon.shp (598 KB) Lars Wikars, 2014-11-30 07:40 AM

Atgard-uppdeladpolygon.shx (2.22 KB) Lars Wikars, 2014-11-30 07:40 AM

History

#1 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Open to Feedback

fresh project? did you checked your snapping options? does it happens with any layer in any project? can you attach sample data?

#2 Updated by Lars Wikars about 5 years ago

Very much thanks for your Quick reply!
It is a Project that I started in QGIS 2.2.
I changed the snapping option according to this video
https://www.youtube.com/watch?v=1xl0qdmaHRg
including marking the box for topological editing and increasing the snapping tolerance.
but the digitizing Tools still works very awkardly (freezes etc)
There are many data layers in my project, but I send a file one of them (originally a forestry database in which I have included my own parameters). For this specific file I tried to divide some of the polygons, without success. I have also tried to create new polygon layers by making polygons by free hand, also without success.

#3 Updated by Giovanni Manghi about 5 years ago

  • Priority changed from High to Normal

Lars Wikars wrote:

Very much thanks for your Quick reply!
It is a Project that I started in QGIS 2.2.
I changed the snapping option according to this video
https://www.youtube.com/watch?v=1xl0qdmaHRg
including marking the box for topological editing and increasing the snapping tolerance.
but the digitizing Tools still works very awkardly (freezes etc)
There are many data layers in my project, but I send a file one of them (originally a forestry database in which I have included my own parameters). For this specific file I tried to divide some of the polygons, without success. I have also tried to create new polygon layers by making polygons by free hand, also without success.

your vector has nothing strange. The problem is probably in your snapping options, if for any reason they got mangled stepping from 2.2 to 2.6 then you should be able to reconfigure them without much effort. Please give it a try and report back.

#4 Updated by Jürgen Fischer about 5 years ago

  • Assignee deleted (Giovanni Manghi)

#5 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Feedback to Closed
  • Resolution set to not reproducable

closing for lack of feedback.

Also available in: Atom PDF