Bug report #11738

Select by location does not work anymore if the intersection layer is a point layer

Added by Giovanni Manghi almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Victor Olaya
Category:Processing/QGIS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:19972

Description

it returns no selection. Seems to work with both lines and polygons.

QGIS 2.6 and master affected.

Processing and ftools affected.

Likely a regression (will test).

History

#1 Updated by Lene Fischer almost 5 years ago

The problem is a regression - same problem from earlier versions.

#2 Updated by Lene Fischer almost 5 years ago

Same problem for function Vector Overlay tool >Intersection

#3 Updated by Giovanni Manghi almost 5 years ago

Lene Fischer wrote:

Same problem for function Vector Overlay tool >Intersection

shouldn't be enough to make intersection be limited just to polygons?

#4 Updated by Alexander Bruy almost 5 years ago

Found the issue. This was caused by old pull-request https://github.com/qgis/QGIS/pull/1495.

#5 Updated by Jon Duckworth almost 5 years ago

Just tried it with the new update (2.6.1-2) and it still seems to be an issue. It's not always returning a blank layer, sometimes it will select a point or two that is correct, but is still missing the vast majority of them.

#6 Updated by Martin Dobias over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

This has been fixed in 84936e59 (processing) and dc156c (ftools)

Also available in: Atom PDF