Bug report #11719

Oracle Data Provider Multiline gap

Added by Nicholas Latham about 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:Jürgen Fischer
Category:Data Provider/Oracle
Affected QGIS version:2.6.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19957

Description

Really hard to explain so I have attached a picture of a multi-line in QGIS. The last section of the first line does not show through. The multi-line shows up as two polylines in Geomedia, the blue one extends out to the red one (highlighted in yellow) and the red one is the same as QGIS. It seems to be QGIS with polylines from Oracle does not show the last section.

Happy to answer questions about it.

Bad_Multiline.PNG (21.2 KB) Nicholas Latham, 2014-11-23 04:35 PM

Bad_Multiline.PNG (25.5 KB) Nicholas Latham, 2014-11-23 04:35 PM

History

#1 Updated by Nicholas Latham about 6 years ago

Added newer screenshot

#2 Updated by Jürgen Fischer about 6 years ago

  • Status changed from Open to Feedback

Please provide a test case.

#3 Updated by Nicholas Latham almost 6 years ago

Jürgen Fischer wrote:

Please provide a test case.

How should I do this? I have found out that ogr2ogr works as expected when converting from Oracle table to shapefile or spatialite.

#4 Updated by Jürgen Fischer almost 6 years ago

Nicholas Latham wrote:

Jürgen Fischer wrote:

Please provide a test case.

How should I do this? I have found out that ogr2ogr works as expected when converting from Oracle table to shapefile or spatialite.

Produce a dump containing some of those geometries. Or can you also reproduce the problem by exporting and reimporting using ogr2ogr?

#5 Updated by Jürgen Fischer almost 6 years ago

  • Status changed from Feedback to Closed

closing for the lack of feedback.

Also available in: Atom PDF