Bug report #11713

Measure tool ellipsoid defaults to 'None/Planametric' regardless of previous ellipsoid selection

Added by Darren Wiens almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Projection Support
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:19951

Description

Using QGIS 2.6.0 Brighton, I want to overlay a shapefile (EPSG: 26910, Nad83 UTM10) over OpenLayers Google Satellite (EPSG: 3857, Pseudo Mercator), and reliably measure distances.

The process is to add the shapefile, then add Google Satellite. The project CRS switches to EPSG:3857, and the shapefile is correctly overlaid. The measure tool does not report correct distance - not surprising, since the CRS is 3857. I do not want to change the CRS because then imagery shifts unexpectedly. So, I change the measure tool ellipsoid in Project Properties to 'GRS 1980'. Hit 'OK' to return to map. The measure tool reports correct distance.

However, if I ever open Project Properties again, the measure tool ellipsoid has defaulted back to 'None/Planametric'. If I hit 'OK' to return to map, the measure tool now reports incorrect distance, presumably because the map plane is unprojected.


Related issues

Related to QGIS Application - Bug report #19902: Advanced Digitizing tool NOT aligned with measurement tool Closed 2018-09-20

Associated revisions

Revision c5b5eee1
Added by Nathan Woodrow almost 5 years ago

Fix #10392 Fix #11713 - Fix selection of ellipsoide when opening project properties

History

#1 Updated by Lene Fischer almost 5 years ago

I have just found the same error.
Starting to show my students the difference between calculating an area with planimetric /ellipsoide difference.
We use EPSG 25832 (UTM32 N EUREF 89)
In the Project properties the Measure tool are set to CRS ON and Ellipsoide None /Planimetric ??? Strange when I have choosen a CRS with an Ellipsoide
Then I change the Ellipsoide to WGS84 – Click on CRS – and sometimes it is set back to None or Clark 1866.

When I try to calculate an area – without any changes in the None /Planimetric – and secondly change the ellipsoide to WGS84 and recalculate – the area gets smaller!!!!!!!

This must be a blocker!!!

#2 Updated by Giovanni Manghi almost 5 years ago

  • Affected QGIS version changed from 2.6.0 to master
  • Target version set to Version 2.8
  • Priority changed from Normal to Severe/Regression
  • Status changed from Open to Feedback
  • Category set to Projection Support

this ticket should be duplicate of #10392 that is alreasy a blocker. Please leave feedback.

#3 Updated by Lene Fischer almost 5 years ago

  • Assignee set to Giovanni Manghi

Hi Giovanni,
I don´t understand the other ticket you refer to.

The problem is that all area calculation is incorrect. And that is a MAJOR issue. If we can´t trust calculated area values...
In my humble opinion, I feel this issue is so important that a bugfix and a version 2.6.2 is needed ASAP.
Regards
Lene Fischer

#4 Updated by Giovanni Manghi almost 5 years ago

  • Assignee deleted (Giovanni Manghi)

Hi Leme

Lene Fischer wrote:

Hi Giovanni,
I don´t understand the other ticket you refer to.

The problem is that all area calculation is incorrect. And that is a MAJOR issue. If we can´t trust calculated area values...
In my humble opinion, I feel this issue is so important that a bugfix and a version 2.6.2 is needed ASAP.

it means that this ticket is, in my opinion, a duplicate of the issue described in #10392 and so it should be closed. #10392 is already a blocker, that means that it must be fixed in time for qgis 2.8 (I am not sure there is any plan for 2.6.2). Cheers!

#5 Updated by Nathan Woodrow almost 5 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

This is a duplicate of #10392 so lets just keep that one open for now.

#6 Updated by Nathan Woodrow almost 5 years ago

As a side note: Does the ellipsoide picker even belong there. I would say something like that should be in the measure dialogs so you can change it on the fly while using it. Or is it normally a set once and leave it kind of thing?

#7 Updated by Jürgen Fischer about 1 year ago

  • Related to Bug report #19902: Advanced Digitizing tool NOT aligned with measurement tool added

Also available in: Atom PDF