Bug report #11683

QGIS 2.6 (Linux) missing option to add File-bases Geodatabase

Added by Flo Ju about 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.6.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:19927

Description

In QGIS 2.6 (Ubuntu 14.10 64bit) the option to add a File-based geodatabase (add vector-data - directory - Esri FGDB) is missing, allthough it was available in 2.4

History

#1 Updated by Giovanni Manghi about 6 years ago

  • Status changed from Open to Feedback
  • Priority changed from High to Normal

you must use a version of gdal that was compiled against the esri file geodatabase api, and as far as I can remember (I'm a ubuntu user) this option was never available out of the box using the official (ubuntugis) repositories.

#2 Updated by Filipe Dias about 6 years ago

I use Ubuntu 14.04 and that option is available in QGIS from ubuntu gis

#3 Updated by Flo Ju about 6 years ago

  • Assignee set to Filipe Dias

Do you use 2.6 in Ubuntu 14.04 ? If Yes, then there is GDAL with FGDB-Support in ubuntu-gis repo ?

UPDATE:
If you install it from http://qgis.org/debian the installation is without FGDB support. I removed everything (QGIS,...) and removed this repo - afterwards installed QGIS 2.6. again from the ubuntugis-repo (ppa:ubuntugis/ubuntugis-unstable). With this installation I have got support for OpenFGDB (but not the native proprietary ESRI FGDB). I have to evaluate if the OpenFGD-connector works for me.

#4 Updated by Jürgen Fischer about 6 years ago

  • Assignee deleted (Filipe Dias)

#5 Updated by Flo Ju about 6 years ago

I tried to describe the "problem": [[http://isticktoit.net/?p=928]]

#6 Updated by Filipe Dias about 6 years ago

Try "Add layer"-> Database -> Type "ESRI Personal Geodatabase"

#7 Updated by Jürgen Fischer almost 6 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

Also available in: Atom PDF