Bug report #11639

Incorrect SchemaLocation URL in WFS POST request

Added by Mattias Spangmyr almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Web Services clients/WFS
Affected QGIS version:2.6.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19892

Description

For a more thorough log walkthrough, see http://gis.stackexchange.com/a/122047/26864

Steps to reproduce:
  1. Add a WFS layer (I added a GeoServer default layer 'tiger:poi')
  2. Make an edit
  3. Try to save your edits

Result: QGIS sends a WFS POST request, which in its contents use "&" in the schema location instead of "&":

xsi:schemaLocation="http://www.census.gov http://my.server/geoserver/wfs?SERVICE=WFS&VERSION=1.0.0&REQUEST=DescribeFeatureType&TYPENAME=tiger:poi&SRSNAME=EPSG:4326"

which results in an empty response from the server, leaving QGIS to wait for the request to time out until responding with e.g.:

Commit errors
Could not commit changes to layer tiger:poi

Errors: ERROR: 1 feature(s) not deleted.

Provider errors:
empty response

History

#1 Updated by Mattias Spangmyr almost 6 years ago

  • Status changed from Open to Closed

Since "&" is a predefined entity in XML the & is a correctly escaped character. The error must be elsewhere.

Also available in: Atom PDF