Bug report #11596

SVG markers have black border when exported as svg through print composer

Added by Steven Bernard over 5 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:2.6.0 Regression?:No
Operating System:OSX Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:19855

Description

When exporting a map through the print composer, most svg markers have a 1pt black border added to them. They are not in the files and the border width on the svg marker is set to 0.

Also the compound paths in the svg collapse leaving solid fills

ss.jpg (69.8 KB) Steven Bernard, 2014-11-07 11:09 AM

svgIcons_pdf.jpg (99.1 KB) Steven Bernard, 2014-11-08 08:03 AM

svgIcons_illustrator_svg.jpg (73.4 KB) Steven Bernard, 2014-11-08 08:03 AM

svgIcons.jpg (381 KB) Steven Bernard, 2014-11-08 08:03 AM

svgIcons.png (819 KB) Steven Bernard, 2014-11-08 08:03 AM

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Category set to Map Composer/Printing
  • Priority changed from High to Normal

#2 Updated by Nyall Dawson over 5 years ago

  • Category changed from Map Composer/Printing to Symbology

Passing over to symbology- composer doesn't do anything specific to alter how maps are rendered, so the bug must lie in the symbology code.

#3 Updated by Nyall Dawson over 5 years ago

  • Status changed from Open to Feedback

Actually, can you first confirm if this affects all output types from composer? Ie, if you save a composer to a PNG image do you see the same?

#4 Updated by Steven Bernard over 5 years ago

I have attached 4 files to show the different formats. The rasterized formats, png and jpg are perfect. But both the svg and pdf versions have issues.

Vector
SVG – svgIcons_illustrator_svg.jpg
PDF – svgIcons_pdf.jpg

Raster
PNG – svgIcons.png
JPG – svgIcons.jpg

#5 Updated by Nyall Dawson over 5 years ago

I can't reproduce this. Can you share a project which demonstrates this issue?

#6 Updated by Steven Bernard over 5 years ago

Hi there, before I send you over a project can you tell me what program you use to create the svgs? I'm wondering if it's an issue with the way qgis reads Adobe illustrator svgs. The markers look absolutely fine within qgis, it's only when the map is exported as an svg and opened up in illustrator that the problem occurs.

#7 Updated by Giovanni Manghi over 4 years ago

what is the status of this issue?

#8 Updated by Giovanni Manghi almost 4 years ago

sorry for asking again, what is the status of this ticket?

#9 Updated by Giovanni Manghi almost 4 years ago

  • Status changed from Feedback to Closed
  • Resolution set to not reproducable

closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF