Bug report #11570

qgis is slow to open attribute table when joining a CSV table without the "memory cache" option

Added by Fabien Cerbelaud almost 6 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:19832

Description

Hi, when I try to open attribute table which contain 31 000 entities it takes a lot of time because of charging only 100 entities per seconds so if I open table with a lot of entites I can't open table quickly. If I stop the process I obtain a table with for example 800 entities and I can't using field calculator because if I do that Qgis crash. In 2.2 version the open attribute table in the same shape are almost instantaneous. I don't know if it normal but it's not really helpfull to work.

CLC_nomenclature_05.csv Magnifier (3.64 KB) Fabien Cerbelaud, 2014-11-12 06:46 AM

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Status changed from Open to Feedback
  • Subject changed from open attribute table to qgis is slow to open attribute table
  • Category set to Vectors

of course it is not the expected behavior but also it does not happen in a clean installation or may be is something that is data related. Please attach a sample of your data.

#2 Updated by Fabien Cerbelaud almost 6 years ago

I can't give you sample of data because it's to big 11Mo but you can download it on https://filex.unilim.fr/get?k=d8WXmEf5lii2IF9XRNU

#3 Updated by Giovanni Manghi almost 6 years ago

table of attributes of your vector opens in a blink of eye here on both Windows and Linux and QGIS 2.6.

What OS do you use? if you are on Windows how did you installed qgis? with the psgeo4w installer or the standalone?

#4 Updated by Fabien Cerbelaud almost 6 years ago

On windows 7, I used the standalone installer

#5 Updated by Giovanni Manghi almost 6 years ago

Fabien Cerbelaud wrote:

On windows 7, I used the standalone installer

so it should be a local issue. Try disable/remove any 3rd plugin, restart qgis and try again.

#6 Updated by Fabien Cerbelaud almost 6 years ago

It works now after restart Qgis, I don't see something different than yesterday or today when the problem appear so I can't explain to you why it's work well now. If this problem come back I'll try to understand why before writing here again. thanks

#7 Updated by Giovanni Manghi almost 6 years ago

  • Status changed from Feedback to Closed
  • Resolution set to invalid

#8 Updated by Fabien Cerbelaud almost 6 years ago

I find why I have a problem to open attribute table, it's because there is a csv join within use cache option. If I join the csv in cache there is no problem but if I join the same csv dynamically the attribute table is very slow to open. I joined to you a csv file which could be join at corine_land_cover data if you want trying.

#9 Updated by Giovanni Manghi almost 6 years ago

  • Subject changed from qgis is slow to open attribute table to qgis is slow to open attribute table when joining a CSV table without the "memory cache" option
  • Resolution deleted (invalid)
  • Affected QGIS version changed from 2.6.0 to master

#10 Updated by Nyall Dawson over 4 years ago

  • Resolution set to invalid
  • Status changed from Reopened to Closed

The cache option exists to fix this very use case. In QGIS 2.16 the cache correctly handles layer updates, so it should be used here to avoid the slow dynamic join.

Also available in: Atom PDF