Bug report #11546

QGIS crash/close unexpectedly after some actions

Added by Miguel Sevilla-Callejo almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:-
Affected QGIS version:2.6.0 Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:Yes Copied to github as #:19816

Description

New released QGIS 2.6.0 crashed/close unexpectedly after some actions like save the project or change from Layers to Browser toolbar tabs but not always.

When it crash saving a project it removes old file and create and empty one (0 Kbs)!!

Here the messages I get when I launch QGIS from CLI and crash (simply changing from Layers to Browser toolbar tabs):

[email protected] ~ $ qgis
Warning: loading of qgis translation failed [/usr/share/qgis/i18n//qgis_en_US]
Warning: loading of qt translation failed [/usr/share/qt4/translations/qt_en_US]
Warning: QGraphicsScene::addItem: item has already been added to this scene
QGIS died on signal 11Could not attach to process.  If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user.  For more details, see /etc/sysctl.d/10-ptrace.conf
ptrace: Operation not permitted.
No thread selected
No stack.
gdb returned 0
Aborted
[email protected] ~ $

I'm trying to produce a proper backtrace file, meanwhile any help is welcome.


Related issues

Related to QGIS Application - Bug report #11593: QGIS crash when working over old project files Closed 2014-11-07
Related to QGIS Application - Bug report #11592: Failure to write the project after removing the liner lay... Closed 2014-11-07

Associated revisions

Revision e49adad1
Added by Matthias Kuhn over 4 years ago

Use cached feature for context menu feature action on attribute dialog

Dirty hack to * fix #11744 * fix #11546

History

#1 Updated by Jürgen Fischer almost 5 years ago

There's a backup copy with ~ appended.

#2 Updated by Gerhard Spieles almost 5 years ago

Same in windows

#3 Updated by Giovanni Manghi almost 5 years ago

  • Status changed from Open to Feedback
  • Target version changed from Version 2.6 to Version 2.8

duplicate of #11537 ?

#4 Updated by Miguel Sevilla-Callejo almost 5 years ago

Apparently no problems at home with Ubuntu LTS 12.04 (Linux kernel 3.13.0-39) and same QGIS version (2.6.0)

#5 Updated by Giovanni Manghi almost 5 years ago

Miguel Sevilla-Callejo wrote:

Apparently no problems at home with Ubuntu LTS 12.04 (Linux kernel 3.13.0-39) and same QGIS version (2.6.0)

different plugins installed?

please try remove/disable all the 3rd party plugins, restart qgis and try see if the crash happens again.

#6 Updated by Giovanni Manghi almost 5 years ago

FYI in case of #11537 it seems that the cause was really a 3rd party plugin, please try disable/remove yours and see if still crashes.

#7 Updated by Giovanni Manghi almost 5 years ago

Giovanni Manghi wrote:

FYI in case of #11537 it seems that the cause was really a 3rd party plugin, please try disable/remove yours and see if still crashes.

#11537 was closed as the probable cause was a faulty 3rd party plugin, please diable/remove them, restart qgis and give it a try again. Thanks!

#8 Updated by Miguel Sevilla-Callejo almost 5 years ago

  • % Done changed from 0 to 100
  • Status changed from Feedback to Closed
  • Target version changed from Version 2.8 to Version 2.6

Yes, It must be any plugin I installed.
I'm running "qgis --noplugins" and it seems it works fine for the moment.
I'll check one by one 3rd party plug ins to find what is crashing QGIS and I'll report it.
Cheers

#9 Updated by Miguel Sevilla-Callejo almost 5 years ago

  • Status changed from Closed to Reopened

NOOO! It crashed again! even with plug-ins disabled... and I lose the project!! When saved it it closed and remove file info (0 bytes!! again).

I paste here again the console message:

[email protected] ~ $ qgis --noplugins
Warning: loading of qgis translation failed [/usr/share/qgis/i18n//qgis_en_US]
Warning: loading of qt translation failed [/usr/share/qt4/translations/qt_en_US]
Warning: QGraphicsScene::addItem: item has already been added to this scene

(qgis.bin:12686): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed

(qgis.bin:12686): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion 'GTK_IS_WIDGET (widget)' failed
^[[1;3AQGIS died on signal 11Could not attach to process.  If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user.  For more details, see /etc/sysctl.d/10-ptrace.conf
ptrace: Operation not permitted.
No thread selected
No stack.
gdb returned 0
Aborted
[email protected] ~ $ 

O_o

#10 Updated by Miguel Sevilla-Callejo almost 5 years ago

  • % Done changed from 100 to 0

Jürgen Fischer wrote:

There's a backup copy with ~ appended.

Thanks a lot I forgot it! Ctrl+H & there it was... mydearprojectfilename.qgs~ :-P

#11 Updated by Giovanni Manghi almost 5 years ago

  • Target version changed from Version 2.6 to Version 2.8

Miguel Sevilla-Callejo wrote:

NOOO! It crashed again! even with plug-ins disabled... and I lose the project!! When saved it it closed and remove file info (0 bytes!! again).

it is just random or it can be linked to a specific operation/data?

#12 Updated by Miguel Sevilla-Callejo almost 5 years ago

  • Target version changed from Version 2.8 to Version 2.6

Here you have backtrace messages running "qgis" (with plug-ins):
http://pastebin.com/F1uTXYBS

Here the console messages:

$ qgis
Warning: loading of qgis translation failed [/usr/share/qgis/i18n//qgis_en_US]
Warning: loading of qt translation failed [/usr/share/qt4/translations/qt_en_US]
Warning: QGraphicsScene::addItem: item has already been added to this scene
QGIS died on signal 11Could not attach to process.  If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user.  For more details, see /etc/sysctl.d/10-ptrace.conf
ptrace: Operation not permitted.
No thread selected
No stack.
gdb returned 0
Aborted (core dumped)
$ 

#13 Updated by Miguel Sevilla-Callejo almost 5 years ago

Here the backtrace messages after running "qgis --noplugins" and crashing when saving the project:
http://pastebin.com/7mV1cA6s

And the console messages again:

$ qgis --noplugins
Warning: loading of qgis translation failed [/usr/share/qgis/i18n//qgis_en_US]
Warning: loading of qt translation failed [/usr/share/qt4/translations/qt_en_US]
Warning: QGraphicsScene::addItem: item has already been added to this scene
QGIS died on signal 11Could not attach to process.  If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user.  For more details, see /etc/sysctl.d/10-ptrace.conf
ptrace: Operation not permitted.
No thread selected
No stack.
gdb returned 0
Aborted (core dumped)
$ 

#14 Updated by Miguel Sevilla-Callejo almost 5 years ago

  • % Done changed from 0 to 100
  • Status changed from Reopened to Closed

Something should change in my system and I do not have any crashes at all since yesterday. May be it's something related with the last update of the system or because I started to make new projects (not reopened some were done with the older version of QGIS)... NO IDEA. I hope all is solve :-/
Thanks to all for the help and the support.

#15 Updated by Miguel Sevilla-Callejo almost 5 years ago

  • Assignee set to Giovanni Manghi
  • Target version changed from Version 2.6 to Version 2.8

Yes, it must be something with the transition from old version projects (2.4.0) to the new one (2.6.0).
Do I open and other issue saying this?
Sometimes when I open an 2.4 project with 2.6 version and try to change and save QGIS crash.
:-/

#16 Updated by Giovanni Manghi almost 5 years ago

Miguel Sevilla-Callejo wrote:

Yes, it must be something with the transition from old version projects (2.4.0) to the new one (2.6.0).
Do I open and other issue saying this?
Sometimes when I open an 2.4 project with 2.6 version and try to change and save QGIS crash.
:-/

yes please, file another ticket and raise the problem in the developers mailing list.

#17 Updated by Jorge Rocha almost 5 years ago

  • Target version changed from Version 2.8 to Version 2.6
  • Status changed from Closed to Reopened
  • Assignee deleted (Giovanni Manghi)

My QGIS is not starting anymore with this same error, either with or without plugins disabled. It crashes immediately at startup, before the main window shows.

[email protected]:~$ gdb qgis.bin
GNU gdb (Ubuntu 7.7.1-0ubuntu5~14.04.2) 7.7.1
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying" 
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from qgis.bin...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/qgis.bin 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffd6a00700 (LWP 24891)]
[New Thread 0x7fffd61ff700 (LWP 24892)]
Warning: QGraphicsScene::addItem: item has already been added to this scene
[New Thread 0x7fffcd724700 (LWP 24895)]
[New Thread 0x7fff83d39700 (LWP 24896)]
[New Thread 0x7fff8309d700 (LWP 24897)]

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff7de3e0d in check_match (sym=0x7ffff480d3a0) at dl-lookup.c:176
176    dl-lookup.c: No such file or directory.
(gdb) continue
Continuing.
QGIS died on signal 11Could not attach to process.  If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user.  For more details, see /etc/sysctl.d/10-ptrace.conf
warning: process 24887 is already traced by process 24884
ptrace: [email protected]:~$ gdb qgis.bin
GNU gdb (Ubuntu 7.7.1-0ubuntu5~14.04.2) 7.7.1
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying" 
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from qgis.bin...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/qgis.bin 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffd6a00700 (LWP 24891)]
[New Thread 0x7fffd61ff700 (LWP 24892)]
Warning: QGraphicsScene::addItem: item has already been added to this scene
[New Thread 0x7fffcd724700 (LWP 24895)]
[New Thread 0x7fff83d39700 (LWP 24896)]
[New Thread 0x7fff8309d700 (LWP 24897)]

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff7de3e0d in check_match (sym=0x7ffff480d3a0) at dl-lookup.c:176
176    dl-lookup.c: No such file or directory.
(gdb) continue
Continuing.
QGIS died on signal 11Could not attach to process.  If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user.  For more details, see /etc/sysctl.d/10-ptrace.conf
warning: process 24887 is already traced by process 24884
ptrace: Operation not permitted.
No thread selected
No stack.
gdb returned 0

Program received signal SIGABRT, Aborted.
0x00007fffefe4ebb9 in __GI_raise ([email protected]=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
56    ../nptl/sysdeps/unix/sysv/linux/raise.c: No such file or directory.
(gdb)ation not permitted.
No thread selected
No stack.
gdb returned 0

Program received signal SIGABRT, Aborted.
0x00007fffefe4ebb9 in __GI_raise ([email protected]=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
56    ../nptl/sysdeps/unix/sysv/linux/raise.c: No such file or directory.
(gdb)

My system: Ubuntu 14.04.1 LTS

QGIS:

apt-cache policy qgis
qgis:
  Installed: 2.6.0+trusty1
  Candidate: 2.6.0+trusty1
  Version table:
 *** 2.6.0+trusty1 0
        500 http://qgis.org/debian/ trusty/main amd64 Packages

#18 Updated by Jürgen Fischer almost 5 years ago

Jorge Rocha wrote:

My QGIS is not starting anymore with this same error, either with or without plugins disabled. It crashes immediately at startup, before the main window shows.

[...]

Please don't quote all these error message just telling you that a backtrace couldn't be produced. Follow the hints in it to produce a usable backtrace. See also Creating a backtrace

#19 Updated by dr - almost 5 years ago

Faced with the same issue - QGIS doesn't start (Ubuntu 14.04, QGIS 2.7):

Warning: QGraphicsScene::addItem: item has already been added to this scene
QGIS died on signal 11[New LWP 9384]
[New LWP 9383]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
0x00007f43df02b619 in __libc_waitpid (pid=9385, stat_loc=0x7fff712f95bc, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:40
40    ../sysdeps/unix/sysv/linux/waitpid.c: Нет такого файла или каталога.
[Current thread is 1 (Thread 0x7f43e71d0800 (LWP 9380))]
#0  0x00007f43df02b619 in __libc_waitpid (pid=9385, stat_loc=0x7fff712f95bc, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:40
        resultvar = 0
        oldtype = 0
#1  0x0000000000501d37 in qgisCrash(int) ()
No symbol table info available.
#2  <signal handler called>
No locals.
#3  0x00000000005931ad in QgsBrowserDockWidget::expandedPathsList(QModelIndex const&) ()
No symbol table info available.
#4  0x0000000000595ff6 in QgsBrowserDockWidget::saveState() ()
No symbol table info available.
#5  0x00000000005960c1 in QgsBrowserDockWidget::hideEvent(QHideEvent*) ()
No symbol table info available.
#6  0x00007f43e152528c in QWidget::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
No symbol table info available.
#7  0x00007f43e18b5dab in QDockWidget::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
No symbol table info available.
#8  0x00007f43e14d5e2c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
No symbol table info available.
#9  0x00007f43e14dc4a0 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
No symbol table info available.
#10 0x00007f43e32cf76b in QgsApplication::notify(QObject*, QEvent*) () from /usr/lib/libqgis_core.so.2.7.0
No symbol table info available.
#11 0x00007f43e213c4dd in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
No symbol table info available.
#12 0x00007f43e152162d in QWidgetPrivate::hide_helper() () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
No symbol table info available.
#13 0x00007f43e1524898 in QWidget::setVisible(bool) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
No symbol table info available.
#14 0x00000000005492e7 in QgisApp::QgisApp(QSplashScreen*, bool, QWidget*, QFlags<Qt::WindowType>) ()
No symbol table info available.
#15 0x00000000004fbc47 in main ()
No symbol table info available.
gdb returned 0

#20 Updated by Matthias Kuhn over 4 years ago

  • Status changed from Reopened to Closed

#21 Updated by Matthias Kuhn over 4 years ago

  • Target version changed from Version 2.6 to Version 2.8
  • Status changed from Closed to Reopened

Sorry for closing, I confused different issues.

#22 Updated by Jürgen Fischer over 4 years ago

  • Status changed from Reopened to Feedback

it this still an issue?

#23 Updated by Giovanni Manghi over 4 years ago

  • Target version changed from Version 2.8 to Version 2.8.2

#24 Updated by Jürgen Fischer over 4 years ago

  • Target version changed from Version 2.8.2 to Future Release - Lower Priority

#25 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

closing for the lack of feedback, please reopen if necessary.

#26 Updated by Valerie Anderson over 4 years ago

  • Status changed from Closed to Reopened

I'm on Debian stretch/sid 61-bit with QGIS 2.8.1 and this started happening to me last week after a routine system update.

qgis --noplugins
Warning: loading of qgis translation failed [/usr/share/qgis/i18n//qgis_en_US]
Warning: loading of qt translation failed [/usr/share/qt4/translations/qt_en_US]
Warning: QGraphicsScene::addItem: item has already been added to this scene
Segmentation [email protected]

Installed: 2.8.1+dfsg1-1+b1
Candidate: 2.8.1+dfsg1-1+b1
Version table:

#27 Updated by Jürgen Fischer over 4 years ago

  • Status changed from Reopened to Closed

Valerie Anderson wrote:

I'm on Debian stretch/sid 61-bit with QGIS 2.8.1 and this started happening to me last week after a routine system update.

Try 2.8.2 or master from our repositories.

Also available in: Atom PDF