Bug report #11474

Cannot move anymore layers in TOC in QGIS master

Added by Giovanni Manghi about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Martin Dobias
Category:Map Legend
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19744

Description

somewhere in between of d833c22 and f2b7c0f (the two master releases available on osgeo4w now) went wrong, and in the latest is not possible to move layers in TOC up/down/inside groups.

Associated revisions

Revision cc306099
Added by Martin Dobias about 5 years ago

Fix #11474 (cannot move layers in layer tree anymore)

I have managed to break that with implementation of #11369.
Obviously it is a bad idea to change selection in a slot connected to model's rowsInserted signals
because the drag'n'drop does not work properly anymore. Now registry bridge will emit a signal after
new layers have been added, so the selection change at that point should be safe.

History

#1 Updated by Giovanni Manghi about 5 years ago

see also #11477

#2 Updated by Martin Dobias about 5 years ago

  • Assignee set to Martin Dobias

My bad, introduced while fixing #11369. For intermediate solution type "iface.layerTreeView().setAutoSelectAddedLayers(False)" in Python console to make it possible to drag'n'drop layers.

#3 Updated by Martin Dobias about 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF