Bug report #11457

Composer map: filter legend by map content doesn't works

Added by Loïc BARTOLETTI over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:19733

Description

filter legend by map content works with map canvas but not with map composer (simple symbol or rule base for my test).
All styles are into legend.

filter_legend_by_map_content.zip - map with tests (15.1 KB) Loïc BARTOLETTI, 2014-10-21 03:03 AM

classes_shown_on_map.png - Legend displays correctly when features are on map (68.1 KB) Nyall Dawson, 2014-10-23 03:04 PM

classes_not_shown_on_map.png - Text still displayed when features not on map (27.7 KB) Nyall Dawson, 2014-10-23 03:04 PM

History

#1 Updated by Nyall Dawson over 5 years ago

  • Affected QGIS version changed from 2.4.0 to master
  • Priority changed from Normal to Severe/Regression

This should be a blocker - it's a new feature which isn't working correctly.

#2 Updated by Jürgen Fischer over 5 years ago

  • Status changed from Open to Feedback

The composer legend in the example file is not assigned to a map. Once it's assigned to the map, the legend filter works.

#3 Updated by Nyall Dawson over 5 years ago

Hmm... There's still an issue here though. In some circumstances only the symbol is removed, not the actual legend text. I've attached screenshots which illustrate this.

#4 Updated by Martin Dobias over 5 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

Then this is duplicate of #11293 (second part of it). Currently when the filtering is turned on, only legend nodes are filtered out, the layer nodes stay in the tree, that's why you can see legend text with no symbol...

Also available in: Atom PDF