Bug report #11440
sip module implements API v11.0 to v11.1 but the qgis.core module requires API v10.1
|Affected QGIS version:
|Pull Request or Patch supplied:
|Crashes QGIS or corrupts data:
|Copied to github as #:
QGIS doesn't load PyQGIS with python 2.7 on Sabayon GNU/Linux, failing with the above error message. I saw there was a similar issue, bug #10174, closed with the explanation that QGIS is shipped with PyQt. Apparently the Sabayon version is not. I'm using the regular Sabayon weekly build which includes sip 4.16.3 and pyqt 4.11.2.
The application works fine but I need PyQGIS to use & modify contributed plugins. The problem may be on your end, or with the way Sabayon packages the application, or just with the fact that they're providing an old QGIS version.
I'll try tinkering further on my own, but I'm sure less technically inclined users are having the same problem. Any recommendations or assistance are welcome and appreciated. Thank you!
#2 Updated by Miran Bozicevic over 9 years ago
Hello Matthias, thanks for the quick reply & for linking to my bug report on Sabayon. I just compiled QGIS 2.4 -- that's what I meant by tinkering further -- and it seems functional with my present setup, complete with PyQGIS. The only extra thing I needed to do was install spatialite, which isn't managed as a Sabayon entropy package, but is available via Gentoo portage.
I can work with what I have, and hopefully Sabayon will update the package in their distro.