Bug report #11409

Merge attributes from selected features tool not working with postgis layers

Added by Alexandre Neto about 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19688

Description

Merge attributes from selected features is not work properly while using postgis layers (works ok with shapefiles).

Trying to merge attributes from existing features, the dialog will not show any row to choose attributes from (see screenshot). On the other hand, if only new features (not yet commited to the database) are selected they will show and the tool seems to work well.

I think this might be related with #11405

merge_attributes_fail.PNG (50.1 KB) Alexandre Neto, 2014-10-14 07:46 AM

merge_attributes_new_features.PNG (51.8 KB) Alexandre Neto, 2014-10-14 07:46 AM

merge_attributes_new_features_and_old_features.PNG (50.4 KB) Alexandre Neto, 2014-10-14 07:46 AM


Related issues

Related to QGIS Application - Bug report #11405: "merge selected features" broke on qgis master Closed 2014-10-14

History

#1 Updated by Jürgen Fischer about 5 years ago

  • Status changed from Open to Feedback

also fixed with d1e23a60 ?

#2 Updated by Alexandre Neto about 5 years ago

  • Status changed from Feedback to Closed

The current master version works as expected.

Also seems to have fixed #11405

Thanks!

Also available in: Atom PDF