Bug report #11299

Null/Extra symbol in categorized layer style

Added by Pekka Helenius almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:2.4.0 Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:19595

Description

For some reason, QGIS Desktop generates an extra/null symbol for categorized layer styles. This happens, at least, on vector layers. The extra symbol need to be removed by an user, manually. The symbol is automatically generated each time you push classify button.

See picture attachment. Symbols 1-5 are correct, and the null symbol at the bottom of the list (blue one) shouldn't be there.

extra_symbol_layerprops.png (83.2 KB) Pekka Helenius, 2014-09-30 06:49 AM

History

#1 Updated by Pekka Helenius almost 5 years ago

  • Target version set to Future Release - Nice to have

#2 Updated by Jürgen Fischer almost 5 years ago

  • Category set to Symbology

#3 Updated by Nathan Woodrow almost 5 years ago

  • Tag changed from layer style categorized symbols null extra to style categorized symbols

This is the fall though style if the none of the others match. If this symbol is not set and you have a value in a new/updated feature that is out of the set range it will not show on the map and you might think that it is not saved or entered correctly.

#4 Updated by Giovanni Manghi almost 5 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Nathan Woodrow wrote:

This is the fall though style if the none of the others match. If this symbol is not set and you have a value in a new/updated feature that is out of the set range it will not show on the map and you might think that it is not saved or entered correctly.

and it is so by design, as far as I know.

Also available in: Atom PDF