Bug report #11297

Composer - Problem with the Y coordinate in the grid frame

Added by Pedro Venâncio about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:19593

Description

There is a problem with the Y coordinate in the "Grid frame", when it reaches the limit of the grid.

Please see the images attached.

In the first image, we see the XY coordinates of the point marked with Grid type "Cross". This is the upper right corner of the Composer.

Moving the map to the East, when the point reaches the edge of the map, the grid frame disappears (image 2).

However, moving the map to the North, there is a position where the Y coordinate label moves from vertical to horizontal, and takes the place of X coordinate label (overlapping labels in image 3).

This behavior only happens when "Frame" option of Map is active, and Thickness is >0.00mm (image 4).

I'm testing in QGIS master (OSGeo4W) in Windows. Curiously, in QGIS 2.4 the same problem seems to happen with the coordinate X.

Ideally, in my view, the labels would disappear as soon as they touch each other, so there is no overlap, but keep the cross, until it disappears from the visible map area in Composer. But this may already be a new feature request, no?

composer_grid_frame_coord_1.png (96.3 KB) Pedro Venâncio, 2014-09-30 06:34 AM

composer_grid_frame_coord_2.png (88.6 KB) Pedro Venâncio, 2014-09-30 06:34 AM

composer_grid_frame_coord_3.png (72.2 KB) Pedro Venâncio, 2014-09-30 06:34 AM

composer_grid_frame_coord_4.png (20.4 KB) Pedro Venâncio, 2014-09-30 06:34 AM

History

#1 Updated by Nyall Dawson about 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #8827

Also available in: Atom PDF