Bug report #11272

Print composer: table frame background extends beyond full table rows

Added by Andreas Neumann almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:Nyall Dawson
Category:Map Composer/Printing
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19570

Description

In print composer, if the frame background extends beyond a multiple of full table row height, the background goes beyond the full table rows (as in the screenshot image provided).

It would be nice if the frame background could be restricted to a multiple of a row-height.

table_bg_issue.png - Background goes beyond the grid of the table (4.82 KB) Andreas Neumann, 2014-09-26 12:48 AM

Associated revisions

Revision 456e9713
Added by Nyall Dawson almost 6 years ago

[composer] Fix table background extending beyond table rows (fix #11272).
It was necessary to add a new 'table background' color option to prevent
regressions when loading old compositions, since users may desire
the old behaviour where the entire frame is filled.

History

#1 Updated by Nyall Dawson almost 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF