Bug report #11223

Vector layer VRT stopped working in master

Added by Maxim Dubinin about 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Data Provider/OGR
Affected QGIS version:master Regression?:No
Operating System:all Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19533

Description

It works fine in 2.2, but in latest master after opening VRT vector features don't show up.

Table opens fine, ogr2ogr works fine, saving works fine as well.

Test data: http://uikgeo.gis-lab.info/data/export/uiks/50.zip

Associated revisions

Revision d2f89c5a
Added by Jürgen Fischer about 5 years ago

don't set relevant fields for VRT data sources when filtering for a rectangle.
OGR might need attributes otherwise considered irrelevant to construct the
geometry to filter against (fixes #11223)

Revision 9a99d2f8
Added by Jürgen Fischer almost 5 years ago

ogr provider: virtual format driver can also be named 'VRT' (fixes #11223)

History

#1 Updated by Maxim Dubinin about 5 years ago

seems to be the case under both Win and Linux

#2 Updated by Alexander Bruy about 5 years ago

  • Affected QGIS version changed from 2.4.0 to master
  • Priority changed from Normal to Severe/Regression
  • Target version set to Version 2.6
  • Operating System set to all

Confirmed. After loading there are no visible features on map, but map extent is correct, attribute table is correct and I can identify (invisible) features with identify tool. Turning on/off simplification, caching and threaded rendering does not helps.

#3 Updated by Jürgen Fischer about 5 years ago

  • Status changed from Open to Closed

#4 Updated by Maxim Dubinin almost 5 years ago

  • Status changed from Closed to Reopened
  • Target version changed from Version 2.6 to Future Release - High Priority

I am afraid this is still not fixed. Confirmed on Windows, Ubuntu and Fedora on two different machines, latest trunk.

#5 Updated by dr - almost 5 years ago

Confirmed. Bug still present.

#6 Updated by Alexander Bruy almost 5 years ago

  • Category changed from Vectors to Data Provider/OGR

#7 Updated by Jürgen Fischer almost 5 years ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF