Bug report #11220

SVG marker not removed from arrow in composer

Added by Spencer Gardner over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.4.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19530

Description

If I add a custom SVG marker to my composer there is no way to remove it again without permanently moving to the default or None. For example, I accidentally assigned my custom marker to the start of the arrow instead of the end. When I removed the path from the text box for the start marker and copied it to the text box for the end marker, my arrow had my custom marker on both ends. My only options for removing the marker from the start of the arrow are to delete the arrow and start over, stick with the default arrow head, or have no arrow heads on either end. Switching off of the SVG option and then returning does not solve the issue.

Associated revisions

Revision 9d0b83ab
Added by Nyall Dawson over 5 years ago

[composer] Allow removing svg markers for arrows (fix #11220)

Previous behaviour was that if the start or end marker was cleared
than the old marker was drawn. This made it impossible to remove
an svg marker from the start or end of the line after one had been
assigned.

Also fix a Qt warning caused by trying to draw markers if the marker
size is set to 0.

History

#1 Updated by Nyall Dawson over 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF