Bug report #11145

Large format export/printing (with transparencies and blending modes) crashes QGIS 2.4 on Windows 32bit

Added by Bernd Eversmann about 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:Jürgen Fischer
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:Yes Copied to github as #:19472

Description

I have a project I need to export as an DIN A0 map. The map contains shapeburst fills, transparencies and objects with blending modes.

This is what happens:
- When I try to export the map in DIN A0 (as .tiff, .jpg or .pdf), choosing print as raster, QGIS crashes, an empty file is created.
- When I export the same map in DIN A3 (raster resolution 300dpi), the file is written correctly.
- When I leave away all special effects (transparencies, blending modes) and do not tick 'print as raster', the file exports without problems in A0 size.
- When I try to export in A2, I get a "bad allocation" error message, and the map including all elements turns into a white page in print composer, until I restart QGIS. An empty file is written.

I am using QGIS 2.4 (osgeo4w installer) on Windows. The problems are the same using the Master (2.5) version.

I think this is quite a serious bug, because it makes it impossible to print cartographically demanding maps in large format.

Bernd


Related issues

Related to QGIS Application - Feature request #11473: Use TLS v1.2 instead of SSL v3 Closed 2014-10-22

History

#1 Updated by Nyall Dawson about 5 years ago

Are you using a 64bit build? If not, I'd suggest you make the switch - 64 bit builds have much better support for large high resolution outputs.

#2 Updated by Bernd Eversmann about 5 years ago

My machine at work is Windows 32bit. Is seems I have to switch. On my Mac (10.9, 64bit) the file export works just fine up to DIN A0, with all sorts of 'special effects' and big raster backgrounds.

That's good to know, but on 32bit machines this problem is still a serious limitation...

#3 Updated by Giovanni Manghi about 5 years ago

  • Affected QGIS version changed from 2.4.0 to master
  • Subject changed from Large format export/printing (with transparencies and blending modes) crashes QGIS 2.4 to Large format export/printing (with transparencies and blending modes) crashes QGIS 2.4 on Windows 32bit

That's good to know, but on 32bit machines this problem is still a serious limitation...

this issue is known since long ago so i don't even know that we should keep this open (because evidently it has no easy solution) and instead document it.

If I'm not wrong 32bit qgis on Linux and OsX does not crash in the same situations, is just a Windows thing.

#4 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Open to Feedback

#5 Updated by Jürgen Fischer almost 5 years ago

  • Assignee set to Jürgen Fischer

#6 Updated by Jürgen Fischer almost 5 years ago

Qt in OSGeo4W 32bit was updated to 4.8.6 - please verify that it also solved the printing issue.

#7 Updated by Bernd Eversmann almost 5 years ago

Unfortunately I don't have access to a Win32 machine with QGIS at the moment. Can anyone else verify?

#8 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

Bernd Eversmann wrote:

Unfortunately I don't have access to a Win32 machine with QGIS at the moment. Can anyone else verify?

seems fine in my tests, please reopen if necessary.

Also available in: Atom PDF