Bug report #11086

Cannot copy point from shapefile layer to shapefile layer

Added by Casper Børgesen over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.4.0 Regression?:No
Operating System:windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19419

Description

I have come upon this simple situation where I want to copy a point from one shape file layer to another shape file layer (see attached files).

Actions to reproduce:

  • Copy the point from layer A.
  • Enable editing on layer B.
  • Paste the point to layer B.
  • Disable/save editing on layer B.

I get the following error report:

Could not commit changes to layer B
Errors: ERROR: 1 feature(s) not added.
Provider errors:
OGR error creating feature -7: Attempt to write non-point (MULTIPOINT) geometry to point shapefile.

The WKT of the point is:

POINT(698816.3309880435699597 6166510.01372888591140509)

Layer A is the result of using the QGIS\\Vector\\Geometry Tools\\Multiparts to singleparts and I would expect the geometry type of the layer to be POINT.

ogrinfo reports the following:

INFO: Open of `A.shp'
using driver `ESRI Shapefile' successful.
1: A (Point)

What is happening here?

B.prj (388 Bytes) Casper Børgesen, 2014-08-21 02:40 AM

B.shp - Target layer (100 Bytes) Casper Børgesen, 2014-08-21 02:40 AM

B.shx (100 Bytes) Casper Børgesen, 2014-08-21 02:40 AM

A.dbf (188 Bytes) Casper Børgesen, 2014-08-21 02:40 AM

A.prj (388 Bytes) Casper Børgesen, 2014-08-21 02:40 AM

A.shp - Source layer (128 Bytes) Casper Børgesen, 2014-08-21 02:40 AM

A.shx (108 Bytes) Casper Børgesen, 2014-08-21 02:40 AM

B.dbf (65 Bytes) Casper Børgesen, 2014-08-21 02:40 AM

History

#1 Updated by Leyan Ouyang over 5 years ago

  • Status changed from Open to Closed

Duplicate of #10747

Also available in: Atom PDF