Feature request #11032

Processing: add option for output type (uint8, unit16,..., float, double) in OTB tools

Added by Giovanni Manghi almost 6 years ago. Updated about 3 years ago.

Status:Rejected
Priority:Normal
Assignee:Victor Olaya
Category:Processing/Core
Pull Request or Patch supplied:No Resolution:up/downstream
Easy fix?:No Copied to github as #:19371

Description

in OTB tools is possible in (all?) tools to define the bit depth of output, example

-out <string> [pixel] Output Image [pixel=uint8/uint16/int16/uint32/int32/float/double] (default value is float) (mandatory)

by default is "float" that many times is not the best option. As in Processing is not possible to change this default then further manipulation of outputs is often needed.

The problem is that this [pixel] definition is not added to the OTB command as any other parameter: it must be added just after the "-out" parameter without any "-" in front of it, exemple:

otbcli_KMeansClassification -in input.tif -out output.tif uint8

this means that this parameter cannot be added in OTB tools definitions files because they will be added to the command line with the "-" causing an error for unrecognized parameter.

I guess that this means that OTBAlgorithm.py must be patched to cope with the "non" parameter.

History

#1 Updated by Alexander Bruy over 5 years ago

  • Category changed from 94 to 120

#2 Updated by Giovanni Manghi about 3 years ago

  • Easy fix? set to No

#3 Updated by Giovanni Manghi about 3 years ago

A few providers are being removed from QGIS3 (they will be available as plugins), so the respective categories are also being removed from the bug tracker. Where necessary the tickets will be reassigned to "processing/core" to not leave them orphaned of category.

#4 Updated by Giovanni Manghi about 3 years ago

Some providers are being removed from QGIS/Processing (will be available as plugin) and so are their categories in the bug tracker. To not leave them orphaned of a category they are being reassigned to processing/core.

#5 Updated by Giovanni Manghi about 3 years ago

  • Category changed from 120 to Processing/Core

#6 Updated by Alexander Bruy about 3 years ago

  • Resolution set to up/downstream
  • Description updated (diff)
  • Status changed from Open to Rejected

Also available in: Atom PDF