Bug report #10984

Not possible to symbolise a no-line border style.

Added by Jonathan Moules almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:19327

Description

Neither of the following two approaches to trying to create invisible borders for a polygon work.

Border Style: "No Pen" - creates a obvious white line where there should be none.

Border Style: Solid Line - set the fill and border colour to the same colour (i.e. RGB: 0,85,0) (dark green) - there's a less obvious white line that's still visible.

History

#1 Updated by Andreas Neumann almost 6 years ago

See email-thread at http://lists.osgeo.org/pipermail/qgis-user/2014-July/028603.html

It is an issue of the rendering library - not a bug in QGIS.

Other rendering libraries, like AGG have solved this issue.

#2 Updated by Giovanni Manghi almost 6 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #10166 and #8861

workaround: uncheck the "makes lines appear less jagged..." option in qgis general settings.

Also available in: Atom PDF