Bug report #10899

Edit widget 'Editable' checkbox stays checked even after unchecking it

Added by Gavin Fleming almost 6 years ago. Updated over 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Matthias Kuhn
Category:Edit widget
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19264

Description

There seems to be no way now to make a field visible but not editable. The 'Immutable' widget has disappeared and unchecking the 'editable' checkbox has no effect since it appears checked again the next time you open Properties. (Tested on text edit widget)

QGIS version 2.5.0-Master QGIS code revision exported
Compiled against Qt 4.8.6 Running against Qt 4.8.6
Compiled against GDAL/OGR 1.11.0 Running against GDAL/OGR 1.11.0
Compiled against GEOS 3.4.2-CAPI-1.8.2 Running against GEOS 3.4.2-CAPI-1.8.2 r3921
PostgreSQL Client Version 9.3.4 SpatiaLite Version 4.1.1
QWT Version 5.2.3 PROJ.4 Version 480
QScintilla2 Version 2.8.1

text_edit_not_editable.png (2.23 KB) Pedro Venâncio, 2014-09-22 03:55 PM

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Priority changed from Normal to Severe/Regression
  • Category set to Edit widget

#2 Updated by Matthias Kuhn almost 6 years ago

  • Status changed from Open to Feedback

Works fine for me.
Can you attach a sample project please.

#3 Updated by Pedro Venâncio over 5 years ago

I do not confirm the problem as described, but confirm the more general problem of, at this moment, there is no possibility of put a visible but not editable field.

This is because in Form View, text fields (text edit widget) despite being marked as not editable ('editable' checkbox unchecked), can be erased with the arrow button (see the image attached). This is a regression. The present form is useful because it allows us to select and copy the contents of the field, but still I think I preferred the old way (gray field, not selectable).

#4 Updated by Matthias Kuhn over 5 years ago

What about the best of both worlds? ;-)

If it's only the clear button, that should be easy to fix.

#5 Updated by Matthias Kuhn over 5 years ago

  • Status changed from Feedback to Closed

Clear button fixed in 72a33ea

The original issue seems not to be reproducible and needs more information. If somebody is able to provide this information, please reopen.

Also available in: Atom PDF