Bug report #10894

Wrong Taudem parameter

Added by Chris George almost 6 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/Core
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19259

Description

The number of processes parameter passed to mpiexec when running a taudem process is passed as a decimal, e.g. "2.0", when it needs to be an integer, e.g. "2".

Associated revisions

Revision 7960dc21
Added by Alexander Bruy almost 6 years ago

[processing] always pass number of cores as integer (fix #10894)

History

#1 Updated by Alexander Bruy almost 6 years ago

  • Status changed from Open to Feedback
  • Category set to 94

Works fine here. Please give more info about issue: which OS, QGIS and Processing versions are you use? Try to clear all Processing settings and check again, as recently some changes were introduces in settings handling

#2 Updated by Chris George almost 6 years ago

I just reinstalled QGIS, including removing my .qgis. Version is 2.4.0. I am using Windows 8.1 on a 64-bit machine. Taudem is version 5.1.2, and so I am using MSMPI. I get the message that the output of PitRemove cannot be loaded, and find it does not exist. I replaced the MSMPI mpiexec.exe with a simple script to collect its parameters and save them. I discover the command being used is

"C:/Program Files/Microsoft MPI/Bin\\mpiexec" "-n" "2.0" ...

When I use this command in a shell (after restoring mpiexec.exe) I get the error message

Error: expecting a positive number of processes following the -n option.

When I replace the "2.0" with "2" all is well. I guess that MPICH2 mpiexec tolerates a decimal number of processes, since you don't have the problem, but MSMPI mpiexec does not.

I realise that Taudem 5.1.2 with MSMPI is not officially supported yet for QGIS, but I need to use it as I have errors with 5.0.6. And it seems a simple fix to QGIS would allow it to be used.

#3 Updated by Alexander Bruy almost 6 years ago

  • Status changed from Feedback to Closed

#4 Updated by Giovanni Manghi about 5 years ago

  • Category changed from 94 to Processing/Core

Also available in: Atom PDF