Bug report #10873

Select by location: does not work as expected

Added by Filipe Dias over 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/Core
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:19241

Description

The option "adding to current selection" does not work.

Also "create new selection" does not work if there is already a selection.

Associated revisions

Revision 8502d11f
Added by Alexander Bruy over 5 years ago

[processing] remove selection before running Select by location algorithm (fix #10873)

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Crashes QGIS or corrupts data set to No
  • Project changed from 78 to QGIS Application
  • Category deleted (61)
  • Affected QGIS version set to 2.4.0

#2 Updated by Giovanni Manghi over 5 years ago

  • Category set to 94
  • Subject changed from Select by location: "adding to current selection" does not work to Select by location: does not work as expected

#3 Updated by Alexander Bruy over 5 years ago

This is because Processing considers existing selection in input layers. If there is a selection, only this selected features will be processed.

Possible workaround for this — forcing selection removal inside algorithm, so this algorithm will clear selection before processing.

#4 Updated by Victor Olaya over 5 years ago

That seems to be a design error in the algorithm. These selection algs should not use only the selction, but the whole layer

#5 Updated by Alexander Bruy over 5 years ago

  • Status changed from Open to Closed

#6 Updated by Alexander Bruy over 5 years ago

  • Resolution set to fixed/implemented

#7 Updated by Giovanni Manghi almost 5 years ago

  • Category changed from 94 to Processing/Core

Also available in: Atom PDF