Bug report #10847

DB Manager: when adding a ; at the end of a query, the layer cannot be loaded as a query layer

Added by Paolo Cavallini about 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:DB Manager
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:19219

Description

It seems that the parsing works differently for query layers when compared with normal queries (an extra ; is added at the end)

History

#1 Updated by Giuseppe Sucameli about 5 years ago

While the query result data are fetched through python connectors, when loading a query layer the query is passed to QGIS provider as it is.

#2 Updated by Sandro Santilli almost 5 years ago

  • Target version set to Version 2.6

as of 2.6.0 I can safely append a semicolon at the end of the query and load the postgis query as a layer.
Can you confirm, Paolo ?

#3 Updated by Giovanni Manghi almost 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

this ticket is/was duplicate of another one, and the issue has been fixed before 2.6 release.

Also available in: Atom PDF