Bug report #10742

Save as PDF from Print Composer, when PDF file already is open

Added by Jakob Lanstorp over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:19126

Description

When saving a PDF file in Print Composer, reusing an already existing file name on disk the PDF file will be overwritten (thats what one would expect). But if the PDF file to be overwritten is already open, the PDF file is NOT saved and no warning is issued.

A warning saying that save is not possibly, since the file is locked would be nice. As for now you get no warning, and have to open the PDF every time you saved it with an existing name, to be sure that the PDF is actually saved. This happens a lot when other people have to quality check your PDF maps on a server driver, but forget to close the PDF after reviewing.

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Status changed from Open to Feedback
  • Category set to Map Composer/Printing

this may have already been fixed in qgis master, please give it a try.

#2 Updated by Nyall Dawson over 7 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Yes - fixed this one yesterday

Also available in: Atom PDF