Bug report #10730

"Fill Ring" does not work as expected in master

Added by Burghardt Scholle over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19116

Description

Hi,
I use the Code Revision d4b067a. In this Revision QGIS does no more make a "hole" in the surrounding polygon, if I execute the "ring fill"-Button (see Image-File "ring1.jpg" below). However, I would like the result as shown in "ring2.jpg". Previous versions show this expected result.

Best regards
Burghardt

ring1.jpg - Ring without hole in the surrounding polygon (12.4 KB) Burghardt Scholle, 2014-06-26 01:19 AM

ring2.jpg - Ring with hole in the surrounding polygon (17.8 KB) Burghardt Scholle, 2014-06-26 01:19 AM

Associated revisions

Revision fec9e65a
Added by Martin Dobias over 7 years ago

Fix #10730 (fill ring does not work as expected)

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Subject changed from "Ring fill" in 2.3 to "Fill Ring" does not work as expected in master
  • OS version deleted (7 (64bit))
  • Operating System deleted (Windows)
  • Target version set to Version 2.4
  • Priority changed from Normal to Severe/Regression
  • Category changed from Browser to Digitising

"Ring fill" in 2.3 it actually works, but it creates twice the polygon to fill the ring.

When suppressing the pop up for the attribute form (pressing CTRL) it works as expected.

#2 Updated by Paolo Cavallini over 7 years ago

  • Target version deleted (Version 2.4)

Confirmed

#3 Updated by Burghardt Scholle over 7 years ago

Ok,
it's a feature not a bug :-). This behavior is a bit unusual for me but if you know it quite usefully. Thank you for the quick reply.

Best regards
Burghardt

#4 Updated by Giovanni Manghi over 7 years ago

Burghardt Scholle wrote:

Ok,
it's a feature not a bug :-). This behavior is a bit unusual for me but if you know it quite usefully. Thank you for the quick reply.

Best regards
Burghardt

no, it's a bug :) it should not work like that.

#5 Updated by Burghardt Scholle over 7 years ago

Oh well, that calms me.

#6 Updated by Martin Dobias over 7 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF